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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to Icepak for beginners and advanced
users. It includes instructions to record, edit, and run a script that generates post-processing
objects.

This chapter contains the following topic:
l Sample Project - The Graphics Card

Sample Project - The Graphics Card
In this project, you will solve the graphics card model and use the Electronics Desktop auto-
mation features to record a script, customize it, and use it to automatically create additional cut
planes.
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Figure 1-1: Graphics Card
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2 - Set Up the Project and Analyze the
Model

This chapter contains the following topics:
l Launch the Ansys Electronics Desktop
l Analyze the Model

Launch the Ansys Electronics Desktop
A shortcut of the Ansys Electronics Desktop application appears on your desktop once the applic-
ation is installed.

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:
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3. ClickOK.

Open the Project

1. On the Desktop ribbon tab, click Open Examples. Then:
a. In theOpen dialog box that appears, double-click the Icepak folder.
b. Select the fileGraphics_Card.aedt and clickOpen.

2. The model is displayed in the 3D Modeler window.

Note: You can hide the grid by selecting View >Grid Settings and then selecting Hide in
theGrid Spacing dialog box. Also, from the View > Coordinate Systemsmenu, you can
hide the large coordinate triad and display a smaller coordinate triad in the bottom of the
3D Modeler window.

Set Up the Project 2-2
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Figure 2-1: Graphics Card model in the 3D Modeler window

3. From the Filemenu, select Save As, and save the project in the desired working dir-
ectory.

Set Up the Project 2-3
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Analyze the Model
1. In the Project Manager, expand Analysis.

2. Under Analysis, right-click Setup1 and select Analyze to run the simulation.
3. Right-click on the solution setup (Setup1) and select Residual to open the Solutions dia-

log box.
4. View the residuals update as the simulation runs.

Note:When the simulation is complete, a message is displayed in theMessage Manager
indicating normal completion.

Set Up the Project 2-4
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3 - Create the Script
Use the Electronics Desktop's automation features to record a script of creating a plane and plot-
ting a field overlay.

Begin Recording the Script
1. On the View ribbon, select Dimetric from theOrient drop-down list.
2. On the Automation ribbon, click Record Script.

3. In the Save As dialog box, browse to your working directory if necessary, enter a File
name, and click Save.

Create a Plane
1. In the History Tree, expandModel > Solids > air.
2. Right-click Region and select View > Show in Active View to display the computational

domain in the 3D Modeler.
3. In the 3D Modeler window, hover the cursor over the center of the max X side of the board

geometry as shown below.

Getting Started with Icepak - Scripting Example

Record the Script 3-1

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak - Scripting Example

4. While the triangle icon is displayed, click to set the location of the plane.
5. While pressing and holding X, move the cursor, and then click to create the plane.

Record the Script 3-2
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Plot Temperature on the Plane
1. In the history tree, expand Planes and select Plane2.
2. In the 3D Modeler window, right-click and select Plot Fields > Temperature > Tem-

perature.

Record the Script 3-3
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3. In the Create Field Plot dialog box, retain the default settings and click Done.

Save an Image

Note:

The orientation of the model in the 3D Modeler window appears as is in the saved
image.

1. From theModelermenu, select Export.
2. In the Export File dialog box, ensure JPEG Files (*.jpg) in the Save as type drop-down

list.
3. Browse to your working directory if necessary, enter a File name, and click Save.

Record the Script 3-4
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Stop Recording the Script
1. Click the Automation ribbon.
2. Click Stop Recording.

Record the Script 3-5
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4 - Edit the Script
Use a plain text editor to customize the script to create multiple plane cuts in the computational
domain.
1. Navigate to your working directory where you previously saved the script.
2. Open the script the with a plain text-editing application.

Important:

Python script formatting (e.g., indentation) can cause syntax errors to occur.

3. As shown in the image below, enter the following code into the appropriate location in the
script. This initializes the numbering applied to planes and plane cut and defines variables
to be used in the script.

num = 0

for xpos in range(-240,80,40):

num = num + 1
plane_name = "plane." + str(num)
post_name = "NAME:Temperature." + str(num)
post_name_img = "Temperature." + str(num)

plane_xpos = str(xpos) + "mm"
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Note:

In the image above, the numbers in line 14 define the X position range (-240 to
80) and the interval (40) at which to create the plane cut and save the image. To
determine the range of a Region (computational domain), use theMeasure >
Position tool from theModelermenu.

4. As shown in the following image in the CreateCutplane function, enter the variable names
for PlaneBaseX and Name.

Edit the Script 4-2
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5. As shown in the following image in the CreateFieldPlot function, replace "NameTem-
perature2" with the variable post_name and "Plane1" with plane_name.

Edit the Script 4-3
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6. As shown in the image below in the ExportModelImageToFile function, enter the following
code into the appropriate location in the script. Also, replace the file path with file_path and
enter post_name_img for FieldPlotSelections.

path_root = "C:/path_to_folder/"
file_name = "temp_cut_x_" + str(plane_xpos) + ".jpg"
file_path = path_root + file_name

Edit the Script 4-4
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Note:

In the image above, the definition of path_root in line 75 specifies the save loc-
ation of the exported images. Use forward slashes when you modify this line to
specify the path to your working directory.

7. Save the script.

Note:

A copy of the edited script is included in the Electronics Desktop installation in the
following folder:

C:\Program Files\AnsysEM\softwareversion\Win64\Help\I-

cepak\Icepak_createcutplanes.py

Edit the Script 4-5
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5 - Run the Script
Run the edited script to automatically create the post-processing objects and cut plane
images.
1. In the 3D Modeler window, ensure the model is displayed in an appropriate orientation to

display the cut planes in the images that will be exported while the script is running.
2. Navigate to the Automation ribbon.
3. Click Run Script.

4. In the Run Script dialog box, browse to your working directory, select the script, and click
Open to run it.

5. After the script has finished running, review the cut planes in the 3D Modeler window.
Note the post-processing objects under Field Overlays in the Project Manager and the
planes in the History Tree.
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6. Navigate to your working directory and review the images of each cut plane created by the
script.

Additional Scripting
You can make modifications to this script to post-process different results, change the image res-
olution, or edit the orientation. See the Icepak Scripting Guide for more information regarding
scripting commands for Icepak features.

Run the Script 5-2
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